#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$"
Local $sString = "#Dessa ska fungera" & @CRLF & _
"ifiske://localhost" & @CRLF & _
"ifiske://notlocalhost" & @CRLF & _
"http://localhost:123" & @CRLF & _
"ifiske://notlocalhost:123" & @CRLF & _
"ifiske://" & @CRLF & _
"http://www.ifiske.se" & @CRLF & _
"https://www.ifiske.se" & @CRLF & _
"http://ifiske.se" & @CRLF & _
"https://ifiske.se" & @CRLF & _
"http://test.ifiske.se:123" & @CRLF & _
"https://abc.ifiske.se" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#Dessa ska inte fungera" & @CRLF & _
"https://test.inteifiske.se" & @CRLF & _
"inteifiske://test:123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")