// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$").unwrap();
let string = "#Dessa ska fungera
ifiske://localhost
ifiske://notlocalhost
http://localhost:123
ifiske://notlocalhost:123
ifiske://
http://www.ifiske.se
https://www.ifiske.se
http://ifiske.se
https://ifiske.se
http://test.ifiske.se:123
https://abc.ifiske.se
#Dessa ska inte fungera
https://test.inteifiske.se
inteifiske://test:123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}