import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?:https?):\\/\\/(?:(?:(?:.+\\.)?ifiske\\.se)|(?:localhost))|(?:ifiske:\\/\\/.*))(?::\\d{1,5})?)$";
final String string = "#Dessa ska fungera\n"
+ "ifiske://localhost\n"
+ "ifiske://notlocalhost\n"
+ "http://localhost:123\n"
+ "ifiske://notlocalhost:123\n"
+ "ifiske://\n"
+ "http://www.ifiske.se\n"
+ "https://www.ifiske.se\n"
+ "http://ifiske.se\n"
+ "https://ifiske.se\n"
+ "http://test.ifiske.se:123\n"
+ "https://abc.ifiske.se\n\n\n"
+ "#Dessa ska inte fungera\n"
+ "https://test.inteifiske.se\n"
+ "inteifiske://test:123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}