re = /^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$/m
str = '#Dessa ska fungera
ifiske://localhost
ifiske://notlocalhost
http://localhost:123
ifiske://notlocalhost:123
ifiske://
http://www.ifiske.se
https://www.ifiske.se
http://ifiske.se
https://ifiske.se
http://test.ifiske.se:123
https://abc.ifiske.se
#Dessa ska inte fungera
https://test.inteifiske.se
inteifiske://test:123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end