using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$";
string input = @"#Dessa ska fungera
ifiske://localhost
ifiske://notlocalhost
http://localhost:123
ifiske://notlocalhost:123
ifiske://
http://www.ifiske.se
https://www.ifiske.se
http://ifiske.se
https://ifiske.se
http://test.ifiske.se:123
https://abc.ifiske.se
#Dessa ska inte fungera
https://test.inteifiske.se
inteifiske://test:123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}