use strict;
my $str = '#Dessa ska fungera
ifiske://localhost
ifiske://notlocalhost
http://localhost:123
ifiske://notlocalhost:123
ifiske://
http://www.ifiske.se
https://www.ifiske.se
http://ifiske.se
https://ifiske.se
http://test.ifiske.se:123
https://abc.ifiske.se
#Dessa ska inte fungera
https://test.inteifiske.se
inteifiske://test:123
';
my $regex = qr/^((?:(?:https?):\/\/(?:(?:(?:.+\.)?ifiske\.se)|(?:localhost))|(?:ifiske:\/\/.*))(?::\d{1,5})?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}