#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https://((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})"
Local $sString = "# Valid" & @CRLF & _
"https://host" & @CRLF & _
"https://some.xyz" & @CRLF & _
"https://some.other.xyz" & @CRLF & _
"https://some.other.one.xyz" & @CRLF & _
"https://my.abc.example-domain.xyz:443" & @CRLF & _
"https://my.abc.example-domain.xyz" & @CRLF & _
"" & @CRLF & _
"# Invalid" & @CRLF & _
"https://my.abc.example-domain.xyz" & @CRLF & _
"https://my.abc.ex|am|ple-|dom|ain|.xyz:443" & @CRLF & _
"https://éhééé.fr" & @CRLF & _
"https://invalid domain.fr" & @CRLF & _
"https://invalid domain" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")