use strict;
my $str = '# Valid
https://host
https://some.xyz
https://some.other.xyz
https://some.other.one.xyz
https://my.abc.example-domain.xyz:443
https://my.abc.example-domain.xyz
# Invalid
https://my.abc.example-domain.xyz
https://my.abc.ex|am|ple-|dom|ain|.xyz:443
https://éhééé.fr
https://invalid domain.fr
https://invalid domain
';
my $regex = qr/https://((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}