import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://((?:[a-z0-9-]+\\.)*)([a-z0-9-]+\\.[a-z]+)($|\\s|\\:\\d{1,5})";
final String string = "# Valid\n"
+ "https://host\n"
+ "https://some.xyz\n"
+ "https://some.other.xyz\n"
+ "https://some.other.one.xyz\n"
+ "https://my.abc.example-domain.xyz:443\n"
+ "https://my.abc.example-domain.xyz\n\n"
+ "# Invalid\n"
+ "https://my.abc.example-domain.xyz\n"
+ "https://my.abc.ex|am|ple-|dom|ain|.xyz:443\n"
+ "https://éhééé.fr\n"
+ "https://invalid domain.fr\n"
+ "https://invalid domain\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}