// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https://((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})").unwrap();
let string = "# Valid
https://host
https://some.xyz
https://some.other.xyz
https://some.other.one.xyz
https://my.abc.example-domain.xyz:443
https://my.abc.example-domain.xyz
# Invalid
https://my.abc.example-domain.xyz
https://my.abc.ex|am|ple-|dom|ain|.xyz:443
https://éhééé.fr
https://invalid domain.fr
https://invalid domain
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}