re = /https:\/\/((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})/
str = '# Valid
https://host
https://some.xyz
https://some.other.xyz
https://some.other.one.xyz
https://my.abc.example-domain.xyz:443
https://my.abc.example-domain.xyz
# Invalid
https://my.abc.example-domain.xyz
https://my.abc.ex|am|ple-|dom|ain|.xyz:443
https://éhééé.fr
https://invalid domain.fr
https://invalid domain
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end