import re
regex = re.compile(r"https://((?:[a-z0-9-]+\.)*)([a-z0-9-]+\.[a-z]+)($|\s|\:\d{1,5})")
test_str = ("# Valid\n"
"https://host\n"
"https://some.xyz\n"
"https://some.other.xyz\n"
"https://some.other.one.xyz\n"
"https://my.abc.example-domain.xyz:443\n"
"https://my.abc.example-domain.xyz\n\n"
"# Invalid\n"
"https://my.abc.example-domain.xyz\n"
"https://my.abc.ex|am|ple-|dom|ain|.xyz:443\n"
"https://éhééé.fr\n"
"https://invalid domain.fr\n"
"https://invalid domain\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")