#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?"
Local $sString = "02-1234-5678#123" & @CRLF & _
"03-123-3339#123" & @CRLF & _
"039-546-469" & @CRLF & _
"039546469" & @CRLF & _
"0981-340-611" & @CRLF & _
"0981340611" & @CRLF & _
"0226665787" & @CRLF & _
"032241234#12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")