use strict;
my $str = '02-1234-5678#123
03-123-3339#123
039-546-469
039546469
0981-340-611
0981340611
0226665787
032241234#12';
my $regex = qr/\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}