import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2,4}-?\\d{3,4}-?\\d{3,4}#?(\\d+)?";
final String string = "02-1234-5678#123\n"
+ "03-123-3339#123\n"
+ "039-546-469\n"
+ "039546469\n"
+ "0981-340-611\n"
+ "0981340611\n"
+ "0226665787\n"
+ "032241234#12";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}