using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?";
string input = @"02-1234-5678#123
03-123-3339#123
039-546-469
039546469
0981-340-611
0981340611
0226665787
032241234#12";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}