package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?`)
var str = `02-1234-5678#123
03-123-3339#123
039-546-469
039546469
0981-340-611
0981340611
0226665787
032241234#12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}