$re = '/\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?/';
$str = '02-1234-5678#123
03-123-3339#123
039-546-469
039546469
0981-340-611
0981340611
0226665787
032241234#12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);