#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=a)(?=b)|(?<=b)(?=a)"
Local $sString = "ab" & @CRLF & _
"aba" & @CRLF & _
"ababa" & @CRLF & _
"aaabbbaaabaaaaaab"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)