$re = '/(?<=a)(?=b)|(?<=b)(?=a)/m';
$str = 'ab
aba
ababa
aaabbbaaabaaaaaab';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;