import Foundation
let pattern = #"(?<=a)(?=b)|(?<=b)(?=a)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ab
aba
ababa
aaabbbaaabaaaaaab
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)