re = /(?<=a)(?=b)|(?<=b)(?=a)/m
str = 'ab
aba
ababa
aaabbbaaabaaaaaab'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result