use strict;
my $str = 'ab
aba
ababa
aaabbbaaabaaaaaab';
my $regex = qr/(?<=a)(?=b)|(?<=b)(?=a)/mp;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";