import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=a)(?=b)|(?<=b)(?=a)";
final String string = "ab\n"
+ "aba\n"
+ "ababa\n"
+ "aaabbbaaabaaaaaab";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}