#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$"
Local $sString = "12" & @CRLF & _
"" & @CRLF & _
"12.12" & @CRLF & _
"" & @CRLF & _
"12 & 129.12 & 11" & @CRLF & _
"" & @CRLF & _
"12 & 129. & 11" & @CRLF & _
"" & @CRLF & _
"12 & .129" & @CRLF & _
"" & @CRLF & _
"12 & 129..1" & @CRLF & _
"" & @CRLF & _
"12 & 129.111" & @CRLF & _
"" & @CRLF & _
"&&&1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12 ---> (pass)" & @CRLF & _
"" & @CRLF & _
"12.12 ---> (pass)" & @CRLF & _
"" & @CRLF & _
"12 & 129.12 & 11 --- >(pass)" & @CRLF & _
"" & @CRLF & _
"12 & 129. & 11 ---> (should not pass)" & @CRLF & _
"" & @CRLF & _
"12 & .129 ---> (should not pass)" & @CRLF & _
"" & @CRLF & _
"12 & 129..1 (should not pass)" & @CRLF & _
"" & @CRLF & _
"12 & 129.111 (should not pass)" & @CRLF & _
"" & @CRLF & _
"&&&1 (should not pass)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")