const regex = /^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:\\.\\d{2})?(?: ?& ?\\d+(?:\\.\\d{2})?)*$', 'gm')
const str = `12
12.12
12 & 129.12 & 11
12 & 129. & 11
12 & .129
12 & 129..1
12 & 129.111
&&&1
12 ---> (pass)
12.12 ---> (pass)
12 & 129.12 & 11 --- >(pass)
12 & 129. & 11 ---> (should not pass)
12 & .129 ---> (should not pass)
12 & 129..1 (should not pass)
12 & 129.111 (should not pass)
&&&1 (should not pass)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}