import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.\\d{2})?(?: ?& ?\\d+(?:\\.\\d{2})?)*$";
final String string = "12\n\n"
+ "12.12\n\n"
+ "12 & 129.12 & 11\n\n"
+ "12 & 129. & 11\n\n"
+ "12 & .129\n\n"
+ "12 & 129..1\n\n"
+ "12 & 129.111\n\n"
+ "&&&1\n\n\n"
+ "12 ---> (pass)\n\n"
+ "12.12 ---> (pass)\n\n"
+ "12 & 129.12 & 11 --- >(pass)\n\n"
+ "12 & 129. & 11 ---> (should not pass)\n\n"
+ "12 & .129 ---> (should not pass)\n\n"
+ "12 & 129..1 (should not pass)\n\n"
+ "12 & 129.111 (should not pass)\n\n"
+ "&&&1 (should not pass)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}