import Foundation
let pattern = #"^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12
12.12
12 & 129.12 & 11
12 & 129. & 11
12 & .129
12 & 129..1
12 & 129.111
&&&1
12 ---> (pass)
12.12 ---> (pass)
12 & 129.12 & 11 --- >(pass)
12 & 129. & 11 ---> (should not pass)
12 & .129 ---> (should not pass)
12 & 129..1 (should not pass)
12 & 129.111 (should not pass)
&&&1 (should not pass)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)