# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)/“/gm;t' <<< "\"Hey\", How are you? \"Hey there\"... “Some more text” and some more \"here\".
"