use strict;
my $str = '"Hey", How are you? "Hey there"... “Some more text” and some more "here".
';
my $regex = qr/"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)/mp;
my $subst = '“';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";