const regex = /"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)', 'gm')
const str = `"Hey", How are you? "Hey there"... “Some more text” and some more "here".
`;
const subst = `“`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);