#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)"
Local $sString = ""Hey", How are you? "Hey there"... “Some more text” and some more "here"." & @CRLF & _
""
Local $sSubst = "“"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)