using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?=(?:(?:[^""]*""){2})*[^""]*""[^""]*$)";
string substitution = @"“";
string input = @"""Hey"", How are you? ""Hey there""... “Some more text” and some more ""here"".
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}