re = /"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)/m
str = '"Hey", How are you? "Hey there"... “Some more text” and some more "here".
'
subst = '“'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result