$re = '/"(?=(?:(?:[^"]*"){2})*[^"]*"[^"]*$)/m';
$str = '"Hey", How are you? "Hey there"... “Some more text” and some more "here".
';
$subst = "“";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;