# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}/$1/gm;t' <<< "{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
"