$re = '/{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}/m';
$str = '{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;