re = /{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}/m
str = '{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result