const regex = /{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}', 'gm')
const str = `{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);