#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m){{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}"
Local $sString = "{{i:very long text with {some} [special](https://google.com) nested text *here*}}" & @CRLF & _
"{{i:hello {{i:hola}}}}" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)