use strict;
my $str = '{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
';
my $regex = qr/{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";