using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{i:((?>(?:(?!{{i:|}}).)+|(?R))*)}}";
string substitution = @"$1";
string input = @"{{i:very long text with {some} [special](https://google.com) nested text *here*}}
{{i:hello {{i:hola}}}}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}