#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=.\n)(.+)\n(?=.)"
Local $sString = "ChapterName" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
"" & @CRLF & _
"AnotherChapterName" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
"" & @CRLF & _
"AnotherChapterName" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
"text text text" & @CRLF & _
""
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)