const regex = /(?<=.\n)(.+)\n(?=.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.\\n)(.+)\\n(?=.)', 'gm')
const str = `ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);