using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=.\n)(.+)\n(?=.)";
string substitution = @"$1 ";
string input = @"ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}