re = /(?<=.\n)(.+)\n(?=.)/m
str = 'ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result