import Foundation
let pattern = #"(?<=.\n)(.+)\n(?=.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)