use strict;
my $str = 'ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
';
my $regex = qr/(?<=.\n)(.+)\n(?=.)/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";