# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R/$3/mg;t' <<< "
a;; z
toy;d;hh
z;
d;23
;;io;
b y;b;12
a;b;bb;;;34
"