const regex = /^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(d|b y|toy);([^;\\r\\n]*);([^;\\r\\n]*)).*\\R', 'mg')
const str = `
a;; z
toy;d;hh
z;
d;23
;;io;
b y;b;12
a;b;bb;;;34
`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);